# ElasticSearch doesn't work with synonym server

**URL:** https://forum.litium.com/t/elasticsearch-doesnt-work-with-synonym-server/2963
**Category:** Questions
**Tags:** search, litium-8
**Created:** [May 29, 2023, 8:28am UTC](https://forum.litium.com/t/elasticsearch-doesnt-work-with-synonym-server/2963 "2023-05-29T08:28:36Z")
**Posts on this page:** 1
**Showing post:** 8

<div class="post-metadata">

### Author: ![joelS](https://avatars.discourse-cdn.com/v4/letter/j/c68b51/32.png) [@joelS](https://forum.litium.com/u/joelS)
#### Post date: [May 30, 2023, 9:35am UTC](https://forum.litium.com/t/elasticsearch-doesnt-work-with-synonym-server/2963/8 "2023-05-30T09:35:08Z")

</div>

I had some issues with elasticsearch, not sure if same as yours, but this helped.

Dynamic synonyms was not installed, changing dns for elasticsearch as suggested by the comment from 192.168.0.2 to 192.168.0.7 and same change for DNS\_FORWARDER. Commenting out as suggeste din URKL beklow also worked, but not sure of implications.

From [The app could not be installed - again (DirectPay)](https://forum.litium.com/t/the-app-could-not-be-installed-again-directpay/2906) changed hosts and LitiumApi\_\_ApiUrl .

In appsettings.json changed to:

> “Server”: “[http://kubernetes.docker.internal:9210](http://kubernetes.docker.internal:9210)”,

Could also be to disk space, if errors in logs in docker maybe reduce memory use, can be sent via Kibana, something like:

> PUT \_cluster/settings  
> {  
> “transient”: {  
> “cluster.routing.allocation.disk.watermark.low”: “30mb”,  
> “cluster.routing.allocation.disk.watermark.high”: “20mb”,  
> “cluster.routing.allocation.disk.watermark.flood\_stage”: “10mb”,  
> “cluster.info.update.interval”: “1m”  
> }  
> }
> 
> PUT /\_all/\_settings  
> {  
> “index.blocks.read\_only\_allow\_delete”: null  
> }

I also got error:

> 2023-05-04 10:56:36.8015 [App:01] [1a7739cb79a53718c3194e258c701e69] [ERROR] [.NET ThreadPool Worker] Litium.Search.Indexing.IndexQueueService - Error in building index document for Litium.Accelerator.Search.ProductDocument with c5595d0a-b159-492e-98e8-610525de3aa3 and “Index”, {“id”:“ProductDocument:c5595d0a-b159-492e-98e8-610525de3aa3”, “primaryTerm”:2, “sequenceNumber”:70014, “version”:2155}: “Stored type System.Collections.Generic.ICollection`1[[System.String, System.Private.CoreLib]], System.Private.CoreLib and requested type System.Collections.Generic.IList`1[[System.String, System.Private.CoreLib]], System.Private.CoreLib does not match.” System.InvalidCastException: Stored type System.Collections.Generic.ICollection`1[[System.String, System.Private.CoreLib]], System.Private.CoreLib and requested type System.Collections.Generic.IList`1[[System.String, System.Private.CoreLib]], System.Private.CoreLib does not match.

Solved by patch:

```auto
// Src/Litium.Accelerator/Search/Filtering/FilterService.cs
- public void SaveProductFilteringFields(ICollection<string> items)
+ public void SaveProductFilteringFields(IList<string> items)

```

---

_[View the full topic](https://forum.litium.com/t/elasticsearch-doesnt-work-with-synonym-server/2963)._
