Block preview doesn't display content

So, we have upgraded a Litium 6 project to Litium 7.
The block preview is not working fine, it seems. It displays as below when tried to preview.

This block has an image in it and expected to display that as a preview.
On console, I could see the below error.

We have set cdnHost for storage.
What could be I’m doing wrong here?

Litium version: 7

Are the store front and the back office running on the same domain? Does the cdn allow CORS requests from the back office’s domain?

We have turned it(cdn) off, now. Now the error is gone. But the warning still stays there and no preview image is displayed.
Below is the warning I can see now. Not sure if its something relates to this

If you switch to Preview mode, does the block display correctly, with image?
Ignore those warning messages. If you look at the network tab, and find request that has Url as: Litium/app/api/websites/block/updatethumbnail/[block-systemId], what does it response?

It displays correctly when on preview mode. But I couldn’t find any request like Litium/app/api/websites/block/updatethumbnail on network tab

When previewing the page, if you inspect the block, does the HTML contain this tag:

<section data-litium-block-id="[block_systemId]">

1 Like

Which tag is it?

sorry, it was stripped out, updated!

Thanks a lot. That worked. That was missing

Glad to hear that. Anyway, it should work without any issue with the default installation of Accelerator, unless if you have customized the way how Block containers are rendered. Please check the last section of the article, where BlockContainerHelperExtension and _BlockContainer.cshtml are documented so you have a better idea of how blocks are rendered.