Can't delete category


There is a category that’s impossible to delete because i got an error. It’s one of the auto generated categories from the accelarator.

I get the following error in backoffice:

Server request failed. Please try again. Litium.Data.DataException: Database operation expected to affect 1 
row(s) but actually affected 0 row(s). Data may have been modified or deleted since entities were loaded. 
See for information on understanding and handling optimistic 
concurrency exceptions.

Litium version: 7 beta

Found the solution for my problem. There was another category that also were linked to the category that i tried to remove. I haven’t specified that link so i assume that link was faulty added by the platform itself. But i removed that faulty link and i could delete the category.

1 Like

What do you mean with that it was another category and how was the category linked?

There was the autogenerated category from the accelerator that was called “Man”. I added a new category, and then tried to removed “Man”, then i got that error. I checked my added category, and it seemed to have a link to the category “Man”. I can’t recall what the setting was called, but after i removed that I were able to delete it.