Exception when sending email using litiumdrift smtpserver

Hi,

I’m trying to send an smtp mail using the mail3.litiumdrift.se server with the following configuration:

Host: mail3.litiumdrift.se
Port: 25
EnableSsl: false
DeliveryMethod: Network
UseDefaultCredentials: true

I’m getting a “Failure sending mail” that was probably caused by a timeout

System.Net.Mail.SmtpException: Failure sending mail. —> System.Net.WebException: Unable to connect to the remote server —> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 81.201.216.52:25

I tried to change some of the settings like EnableSsl to true (trial-error) but could not get it to go.
After some googling around, I found that there are other litiumdrift servers:
mail.litiumdrift.se
mail1.litiumdrift.se
mail2.litiumdrift.se
mail4.litiumdrift.se

I tried these but I keep getting the same exception.

Also tried turning off my firewall just to rule out this scenario but I got the same result.

Probably there’s something wrong with my configuration like the port and credentials.

Has anyone encountered this before?

Please advise and thanks in advance.

Litium version: 7.4

Are you trying to sent mail through that server from your local machine or from the hosting-server for the customer?

Thank you so much for the response.

I am trying to send a mail using my local machine through the server.

That will not be possible, that servers are only accepting to send mails from the servers in Litium Cloud.

If you need to send mail from your local machine you need to have another mailserver, either from your ISP or a dummy one if it only is for testing example PaperCut-SMTP or MailHog.

1 Like

Got it! Thank you so much for the advise.

1 Like