Install Accelerator Package - "An error occurred during installation"


I tried to get Litium 8 up and running on my PC and I have been able to get everything running up until the accelerator deployment where I get the “An error occurred during installation”. The only other details I get are to check the logs.

Checking the logs reveals the following error:

2021-08-18 15:42:44.3487 [App:01] [] [ERROR] [] Litium.Accelerator.Administration.Extensions.Controllers.DeploymentController - Error when deploying accelerator. End of Central Directory record could not be found. System.IO.InvalidDataException: End of Central Directory record could not be found.
at System.IO.Compression.ZipArchive.ReadEndOfCentralDirectory()
at System.IO.Compression.ZipArchive…ctor(Stream stream, ZipArchiveMode mode, Boolean leaveOpen, Encoding entryNameEncoding)
at System.IO.Compression.ZipArchive…ctor(Stream stream, ZipArchiveMode mode, Boolean leaveOpen)
at Litium.Web.Administration.Runtime.ZipFileProvider…ctor(Stream zipStream, String subPath)
at Litium.Accelerator.Administration.Extensions.Deployments.AcceleratorPackage.MapBlobs(Stream containerStream)
at Litium.Accelerator.Administration.Extensions.Deployments.AcceleratorPackage.GetStructureInfoAsync()
at Litium.Accelerator.Administration.Extensions.Controllers.DeploymentController.ImportPackage(ImportViewModel importForm)

Any tips? Or should I just create a bug report?

Litium version: 8.0.0-beta-2-2106230912

Does your machine has internet connection when executing the deployment? Please check the firewall configuration to make sure it allows Accelerator to download files from the outside network.

Also check if there is any file under %TEMP%\Litium_accelerator_deployments

If you find the packages in the above folder, could windows extract the files manually into another directory?

The Litium_accelerator_deployments contains a sub-folder with 2 files; Accelerator_B2C.bin (122kb) and (6876kb).

Maybe I can delete these files and force Litium to download them again?

Seems that the issue has something to do with downloading the I’ve removed the Litium_accelerator_deployments folder, tried re-deploying, and the storage file is larger this time (13040kb), but I still get an error:

“Http failure response for https://localhost:44341/site/administration/extensions/api/deployment/import: 0 Unknown Error”

Here is logging of the response:

2021-08-19 09:20:12.2295 [App:01] [] [INFO ] [] System.Net.Http.HttpClient.accelerator-deployment.LogicalHandler - End processing HTTP request after 31.9283ms - 200 
2021-08-19 09:20:12.2295 [App:01] [] [TRACE] [] System.Net.Http.HttpClient.accelerator-deployment.LogicalHandler - Response Headers:
Connection: keep-alive
Cache-Control: max-age=300
Content-Security-Policy: default-src 'none'
ETag: "dfa702b594c2b057ad80926147b75b85d0d3a9c8b699eec5389e521b675be6bb"
X-Content-Type-Options: nosniff
X-Frame-Options: DENY
X-XSS-Protection: 1; mode=block
Via: 1.1 varnish, 1.1 varnish, 1.1 varnish
Access-Control-Allow-Origin: *
X-Fastly-Request-ID: 42c6b6cea3ed7ddc2820066fd5198ad84dd520d0
Source-Age: 9
Accept-Ranges: bytes
Age: 407
Date: Thu, 19 Aug 2021 07:20:12 GMT
X-Origin-Url: /media/LitiumAB/Litium.Accelerator.Deployments/b99c64c/src/
X-Served-By: cache-bma1680-BMA, cache-bma1633-BMA, cache-hhn4023-HHN
X-Cache-Hits: 0, 0, 0
X-Timer: S1629357612.226637,VS0,VE0
Vary: Authorization, Accept-Encoding
Content-Length: 589922909
Content-Type: application/octet-stream
Last-Modified: Thu, 19 Aug 2021 07:13:15 GMT
Expires: Thu, 19 Aug 2021 07:18:25 GMT

Can you manually download the (file is about 0.5GB) and put into the above folder, looks like you getting timeouts in the download and then the file will be broken.

Downloaded :+1: and had to do the same for and (even though these files are small in comparison)

Now the deployment fails with the following error in the logs:

2021-08-19 10:36:14.4262 [App:01] [] [ERROR] [] Litium.Accelerator.Administration.Extensions.Controllers.DeploymentController - Error when deploying accelerator. Validation error for Assortment(SystemId: d5a31287-06c3-4e41-828f-291fbaba9dcc, Id: 3A15B40C-D0BF-4CD4-9737-6B6C7D2546EFdemo), Id: 'Värdet är inte unikt.'. Litium.Validations.ValidationException: Validation error for Assortment(SystemId: d5a31287-06c3-4e41-828f-291fbaba9dcc, Id: 3A15B40C-D0BF-4CD4-9737-6B6C7D2546EFdemo), Id: 'Värdet är inte unikt.'.
   at Litium.Validations.ValidationServiceExtensions.ThrowExceptionIfError[T](ValidationService service, T entity, ValidationMode validationMode)
   at Litium.Application.Data.Batching.BatchDataImpl.Execute[T](T entity, ValidationMode validationMode)
   at Litium.Application.Data.Batching.BatchDataImpl.WrapAndExecute[T](T entity, ValidationMode validationMode)
   at Litium.Application.Data.Batching.BatchDataImpl.Create[T](T entity)
   at Litium.Application.Products.AssortmentServiceImpl.Create(Assortment assortment)
   at Litium.Accelerator.Administration.Extensions.Deployments.AcceleratorPackage.CreateAssortment(StructureInfo structureInfo, String name, String domainName)
   at Litium.Accelerator.Administration.Extensions.Deployments.AcceleratorPackage.CreatePackageInfo(StructureInfo structureInfo, String name, String domainName)
   at Litium.Accelerator.Administration.Extensions.Controllers.DeploymentController.ImportPackage(ImportViewModel importForm)

So then I restored the database thinking that “currupted” data might have resulted from previous failures. Then I tried again to create “demo” with domain “localhost:5001”, but that still failed.
Then I tried to create “demo2” with domain “localhost:5002” and I get a validation error saying that the domain already exists.
Then there is an error when I try checking out the domains.

All the while no errors are logged.

Also something unexpected is that it seems that the application is “starting” on every click. I see the following appear in the logs each time I click something in backoffice:

2021-08-19 11:13:22.7727 [App:01] [] [INFO ] [] Litium.Accelerator.MvcCore.Program - Application starting 
2021-08-19 11:13:25.0247 [App:01] [] [DEBUG] [] Microsoft.Extensions.Hosting.Internal.Host - Hosting starting

Are you using Redis in your current installation? Did you in that case also flush the cache to not contain the data from the previous database that you replaced?

No Redis, I figured I could set that up at a later stage.

The only thing I’ve done outside of the current L8 install instructions was putting the connection string in a appsettings.Development.json file along with a shared folder.

So, this morning I tried again, but this time I ran the application with debugging. The application this time does not reload on each click and the deployment appears to have worked!

Running without debugging and the application restarts on each click. I am assuming this is not the correct behavior?

No, the application should not restart on each click, that is something that not are correct there.

Are you running inside IIS, IIS Express or as standalone application?

Just running it out-of-the-box with IIS Express at the moment.

Can it be something similar to c# - Why does IIS Express shut down the Application and restart it all the time? - Stack Overflow?

This is not the case. There is not other application running that would modify the contents of the bin folder while running the application.

This actually only appears to be an issue when running and deploying the accelerator the first time. If I run the application with the debugger attached then the application does not restart and I can deploy the accelerator without error. After that, I can run the application without debugging and it runs fine.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.