Install Direct payment/Shipment locally

Hey, problem when im trying to install directpayment and shipment locally!

After setting up a developer certificate that is described here:

And also setting up the docker-compose file as explained here:

I get this error when im calling the payment/shippment apps for the first time (installment call) this log is from the direct payment log. data\directpayment\logs\messages.log

2022-03-31 23:34:41.1103 [App:01] [] [ERROR] [] Microsoft.AspNetCore.Server.Kestrel - Connection id "0HMGJDS3CEJ0T", Request id "0HMGJDS3CEJ0T:00000002": An unhandled exception was thrown by the application. System.InvalidOperationException: IDX20803: Unable to obtain configuration from: 'System.String'.
 ---> System.IO.IOException: IDX20807: Unable to retrieve document from: 'System.String'. HttpResponseMessage: 'System.Net.Http.HttpResponseMessage', HttpResponseMessage.Content: 'System.String'.
   at Microsoft.IdentityModel.Protocols.HttpDocumentRetriever.GetDocumentAsync(String address, CancellationToken cancel)
   at Microsoft.IdentityModel.Protocols.OpenIdConnect.OpenIdConnectConfigurationRetriever.GetAsync(String address, IDocumentRetriever retriever, CancellationToken cancel)
   at Microsoft.IdentityModel.Protocols.ConfigurationManager`1.GetConfigurationAsync(CancellationToken cancel)

I have tried to call the app with domain name + port, and also localhost + port. Both give the same error.

Litium version: 8.2.0/8.3.0

The problem is that the container cannot access litium to authenticate itself.
Is the localtest domain used that we recommend in our documentation or something else? If something else is used, the localtest domain should be used instead.

im using a localtest domain as follows:

@steve.redstorm any ideas? Im usinfg recomended settings.

Can you remove them and go with docs description and try?

@steve.redstorm We have done that, Im not the only one with this issue right now. I have also tried to change ports, I even cleaned my docker containers/images and started over.

the domain is pointing to localhost, it’s the first request that dosent really work.
When i talked to others who had similar problems they said it’s when the service accounts are beeing created?

I can show you a demo of it if you guys are avalible, Im spending way to much time to install a payment provider locally right now.

Yes, that would be good. Create a support case so we proceed it the right way.

Me and 2 other developers also have this issue now. Still on Litium 8.2.3. But something must have happended in the last days.

Update: Seems to work when running from Docker desktop, and not from the terminal. (Even with admin)

Hej @Ericsj11 , I am running docker as administrator and from docker desktop, the containers is running as they should, they start withouth any problem and have 0 logs of errors (that I can find)

Litium have been kind enough to setup a meeting to see what happens, so let’s see what the outcome is from that meeting.

1 Like

The issue was due to changes made in the dnsresolver container that changed how parameters should be supplied. An updated docker-compose for the shared dependencies has been added to Docs: Shared dependencies


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.