Product and Category search return 0 results in test but locally it works as expected

Hi!
I’m working with a project which we’ve installed the headless API. In this I have created an Endpoint for searching products and categories. The code looks like this:

   var searchRequest = new QueryRequest(language.SystemId, ProductCatalogSearchDomains.Products, Solution.Instance.SystemToken)
        {
            Text = searchQuery,
            Paging = new Paging(page, numberOfResults)
        };
        var response = Solution.Instance.SearchService.Search(searchRequest);
        foreach (Hit hit in response.Hits)

This works locally but after deployment to test server every request to the endpoint returns zero results. ServiceAccount is used for authentication. Other endpoints works as expected. I also tried SearchDomains.Products and SearchDomains.Categories and works locally but not in test.

The local website and test site both have two websites in the litium instance set up with their corresponding channels and markets based on the same assortment.

Reindexing has not worked so far.

Regular search on the website works as exptected and present results.

Litium version: 7.2.2
Litium version (Headless): 7.2.0

Edit:
Seems like it works to search for brand names but not anything else for products (or any category).