Verification fails after upgrade to Dibs addon 4.7.100


After upgrade to Litium.Studio.AddOns.Dibs.4.7.100 the payment provider result always returns:


Before upgrading I could past the URL and get an OK back. Maybe I missed something when upgraded?



Litium version: 5.6.5

From which version did you upgrade? And this url is the direct server to server call back, it is not guaranteed it will work if you just try to browse to it.
Instead, if you put the trace mode on, and let dibs communicate with it, does it result in errors?

Does it exists any assembly redirect warnings in the build log when you rebuild the solution?

Yes, I got. Fixed them but still the same.

Upgraded from 3.3 to 4.7.100.
The url is generated in test mode from Dibs so I just cut and paste from the popup window. Before upgrade that worked just perfect and our Litium order got the correct status.
This only affects direct bank payments. Credit card payments works perfect in test but I don’t dare to push the code to production since the call above.

Found this in the log now:
2019-04-03 08:59:14.6651 [App:02] [0c4ddf07-a8db-4b35-a240-a467eba52d75] [ERROR] [] Litium.Studio.AddOns.Dibs.DibsProvider - DibsCould not determine the paymentInfo for a HTTPReport with transactionRef 0

Before upgrading the Url looked the same: “ref=0”.
I guess that is the transactionRef.

Return url in Dibs are set to:
http://domain/PaymentProviderResult.axd/StaticCallback/Dibs, is this correct?

Is the HTTP Report configured?

Yes it is. We only had one so I created a new for test but no luck, still fail.

http://domain/PaymentProviderResult.axd/Report/Dibs?ref=[ver id no]&reply=[ver reply]&replyExt=[ver replyExt]&sum=[ver sum]&referenceData=[ver valueof=“referenceNo”]&currency=[ver valueof=“currency”]&expY=[ver sysinfo=“expY”]&expM=[ver sysinfo=“expM”]&authCode=[ver sysinfo=“authCode”]&ccPrefix=[ver sysinfo=“ccPrefix”]&ccType=[ver sysinfo=“ccType”]

2019-04-03 10:49:20.0938 [App:04] [] [ERROR] [] Litium.Studio.AddOns.Dibs.DibsProvider - DibsCould not determine the paymentInfo for a HTTPReport with transactionRef 0
2019-04-03 10:49:20.0938 [App:04] [] [ERROR] [] Litium.Studio.AddOns.Dibs.DibsProvider - Dibs Http report callback failure. Corresponding payment not found for HTTP report callback http://domain/PaymentProviderResult.axd/Report/Dibs?ref=0&reply=A&replyExt=P&sum=200,00&referenceData=LS900107&currency=SEK&expY=&expM=&authCode=&ccPrefix=&ccType=&MAC=79742D131E8072DCDAEF254C0E7B407E389D6F96

This worked just fine before upgrade and maybe it will work just fine in production, I just want to be sure before we deploy.

Any ideas? Can we deploy safely even though this do not work?

I don’t know why the ref is zero, it should not be zero. It is not related to the upgrade, Dibs is not sending the information in the call according to the error report above.
Until it is verified with Dibs, we cannot be sure whether it will work in Production. So would you contact dibs first, and ask why the parameter ref is zero in a Http report please?

Dibs says that this is how it works. If it is a test call there will be no reference and there for I guess it will never work in test. The strange thing is that it has always been 0 in test and before upgrade to 4.7.100 the http report returned OK, that must be something that is new in the upgrade?
I guess we just have to deploy to production and hope for the best.